Juspay - Timeouts observed for Express Checkout APIs – Incident details

Timeouts observed for Express Checkout APIs

Resolved
Degraded performance
Started 1 day agoLasted 2 minutes

Affected

API

Degraded performance from 11:34 AM to 11:36 AM

Payment Page

Degraded performance from 11:34 AM to 11:36 AM

Updates
  • Resolved
    Resolved

    One of our database writer instances based out of AWS Mumbai DC had a hardware failure. AWS tried to automatically failover the instance to a healthy one, but from the logs we could see that the failover got stuck and hence delayed, causing an intermittent spike in latencies, affecting a small portion of our overall volume.

    We are working with AWS to understand why the process was stuck and delayed.

  • Identified
    Identified

    Initial analysis indicates hardware failure of one our AWS database writer instances resulting in 504s and timeouts of our APIs.