Juspay - Core APIs experienced timeouts – Incident details

Core APIs experienced timeouts

Resolved
Partial outage 30 %
Started 7 days agoLasted 2 minutes

Affected

API

Partial outage from 5:20 AM to 5:22 AM

Payment Page

Partial outage from 5:20 AM to 5:22 AM

SDK

Partial outage from 5:20 AM to 5:22 AM

Updates
  • Resolved
    Resolved

    The issue was caused by an automated failover that occurred in our KV infrastructure hosted on AWS, which led to temporary increase in 5XX errors. The system detected an issue with primary nodes and automatically promoted replicas to maintain service continuity. The failover completed automatically, and all systems recovered without manual intervention.

  • Investigating
    Investigating
    We are currently investigating this incident.